載入中...
在線檢測未來函數
載入中...

通達信紅升彩色主圖指標公式

來源:Internet,編輯:股旁網,2018-10-15

JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2)); {GUPIAOFF.COM}
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
紅色持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;
離場:=IF(紅色持股,JRL,DRAWNULL);
明離場價:=離場,COLORFF99FF,NODRAW;
今離場價:REF(離場,1)COLOR0000FF,NODRAW;
青色觀望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;
進:=IF(青色觀望,JRH,DRAWNULL);
明進場價:=進,COLOR33AACC,NODRAW;
今進場價:REF(明進場價,1),COLORFF0000,NODRAW;
短買:VAR19,COLOR33AACC,NODRAW;
品紅離場:VAR1A,COLORFF99FF,NODRAW;
急速超跌:(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORFFFFFF,NODRAW;
上市日期年:REF(YEAR,BARSCOUNT(CLOSE)-1),NODRAW,COLOR0000FF;
月:REF(MONTH,BARSCOUNT(CLOSE)-1),NODRAW,COLORFF00FF;
日:REF(DAY,BARSCOUNT(CLOSE)-1),NODRAW,COLOR00FFFF; {GUPIAOFF.COM}
紅升線:(20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211,COLOR0000FF;
牛熊線:MA(CLOSE,26),COLORFF00FF;
等待:=IF(MA3>紅升線,紅升線,MA3);
IF(等待>REF(等待,1),等待,DRAWNULL),LINETHICK2,COLOR00FFFF;
IF(紅升線>REF(紅升線,1),紅升線,DRAWNULL),LINETHICK2,COLOR0000FF;
IF(紅升線<REF(紅升線,1),紅升線,DRAWNULL),COLOR00FF00;
IF(牛熊線>REF(牛熊線,1),牛熊線,DRAWNULL),LINETHICK1,COLORFF00FF;
IF(牛熊線<REF(牛熊線,1),牛熊線,DRAWNULL),COLOR669933;
STICKLINE(ISLASTBAR AND (紅色持股 OR REF(紅色持股,1)=1),今離場價,今離場價,30,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND (青色觀望 OR REF(青色觀望,1)=1),今進場價,今進場價,30,1),COLOR00FF00;
STICKLINE(C>=O,L,H,0,0),COLOR0000CC;
STICKLINE(C<O,L,H,0,0),COLOR999900;
STICKLINE(1,C,O,3.5,0),COLOR858500;
STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5;
STICKLINE(紅色持股,CLOSE,O,2.8,0),COLOR000055;
STICKLINE(紅色持股,CLOSE,O,2,0),COLOR000088;
STICKLINE(紅色持股,CLOSE,O,1.5,0),COLOR0000AA;
STICKLINE(紅色持股,CLOSE,O,1,0),COLOR0000CC;
STICKLINE(紅色持股,CLOSE,O,0.5,0),COLOR0000EE;
STICKLINE(青色觀望,CLOSE,O,2.8,0),COLOR555500;
STICKLINE(青色觀望,CLOSE,O,2,0),COLOR888800;
STICKLINE(青色觀望,CLOSE,O,1.5,0),COLORAAAA00;
STICKLINE(青色觀望,CLOSE,O,1,0),COLORCCCC00;
STICKLINE(青色觀望,CLOSE,O,0.5,0),COLOREEEE00;
CO:=(C-O);
STICKLINE(急速超跌,O,C-CO/2,2.8,0),COLOR555555;
STICKLINE(急速超跌,O,C-CO/2,2,0),COLOR888888;
STICKLINE(急速超跌,O,C-CO/2,1.5,0),COLORAAAAAA;
STICKLINE(急速超跌,O,C-CO/2,1,0),COLORCCCCCC;
STICKLINE(急速超跌,O,C-CO/2,0.5,0),COLOREEEEEE;
STICKLINE(短買,O,O+CO/3,2.8,0),COLOR335555;
STICKLINE(短買,O,O+CO/3,2,0),COLOR338888;
STICKLINE(短買,O,O+CO/3,1.5,0),COLOR33AAAA;
STICKLINE(短買,O,O+CO/3,1,0),COLOR33CCCC;
STICKLINE(短買,O,O+CO/3,0,0),COLOR33EEEE;
DRAWTEXT(短買,REF(CLOSE,1),'←買入'),COLOR33FFCC;
STICKLINE(品紅離場,O,O+CO/3,2.8,0),COLOR550055;
STICKLINE(品紅離場,O,O+CO/3,2,0),COLOR880088;
STICKLINE(品紅離場,O,O+CO/3,1.5,0),COLORAA00AA;
STICKLINE(品紅離場,O,O+CO/3,1,0),COLORCC00CC;
STICKLINE(品紅離場,O,O+CO/3,0.5,0),COLOREE00EE;
DRAWTEXT(品紅離場,REF(CLOSE,1)+0.1,'拋盤'),COLORFF99FF;

通達信紅升彩色主圖指標公式

 

相關文章

高手二肖中特