載入中...
在線檢測未來函數
載入中...

通達信四季發財指標公式

來源:Internet,編輯:股旁網,2019-02-11

A1X:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))
/(HHV(H,55)-LLV(L,55))*100,5,1);
潘金蓮:=EMA(A1X,5),LINETHICK2,COLOR6600FF;
A2X:=(潘金蓮-REF(潘金蓮,1))/REF(潘金蓮,1)*100;
A3X:=EMA(C,5);
A4X:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
王婆牽線:=(MA(3*SMA(A4X,6,1)-2*SMA(SMA(A4X,5,1),5,1),2)),LINETHICK2,COLORYELLOW;
A5X:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100;
機會來臨:=REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1)
,COLORF00FF0,LINETHICK2;
A1:="KD.K#DAY"(9,3,3);
A2:="KD.D#DAY"(9,3,3);
AA1:=(A1+A2)/2;
A3:="KD.K#WEEK"(9,3,3);
A4:="KD.D#WEEK"(9,3,3);
A5:="KD.K#MONTH"(9,3,3);
A6:="KD.D#MONTH"(9,3,3);
A7:="KDJ.J#WEEK"(9,3,3);
A8:="KD.K"(9,3,3);
A9:="KD.D"(9,3,3);
STICKLINE( A1>A2,2 ,2.5 ,5 ,0 ),COLORLIRED;
STICKLINE( A1<A2,2 ,3 ,5 ,0 ),COLORBLACK;
STICKLINE( A3>A4,2 ,0.5 ,5 ,0 ),COLORGRAY;
STICKLINE( C>0,0.5 ,0.5 ,5 ,0 ),COLOR555555;
STICKLINE( C>0,2 ,2,10 ,0 ),COLOR555555;
K:=A8*3/120;
D:=A9*3/120;
J:=A7*3/120;
AA2:=AA1*3/120;
DRAWBAND(A3*3/120,RGB(250,00,300),A4*3/120,RGB(00,250,300));
STICKLINE(K>D,K,D,5,1),COLORRED;
STICKLINE(K<=D,K,D,5,1),COLORLIGREEN;
OK:=REF(CLOSE,1);
魚:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100;
RSI4:=SMA(魚,7,1);
HH:=BARSLAST(魚<=15)<5;
白綠線:=SMA(魚,7,1);
深水魚:=CROSS(魚,RSI4) AND 白綠線>15 AND HH;{15}
BU:=深水魚;
BB2:=IF(C>REF((6*H+5*REF(H,1)+4*REF(H,2)+3*REF(H,3)+2*REF(H,4)+1*REF(H,5))/(6+5+4+3+2+1)
,1),1,IF(C<REF((6*L+5*REF(L,1)+4*REF(L,2)+3*REF(L,3)+2*REF(L,4)+1*REF(L,5))/(6+5+4+3+2+1)
,1),-1,0));
DD2:=BARSLAST(NOT(BB2=0));
BF:=IF(BB2=0,REF(BB2,DD2),BB2);
魚躍龍門:BU,NODRAW,COLORRED;
止損:C<REF(O,BARSLAST(BU>0)) AND COUNT(C<REF(O,BARSLAST(BU>0)),BARSLAST(BU>0))
=1 AND IF(MA(CLOSE,1)>IF(BF=-1,MA(HIGH,1.01),MA(LOW,1.01)) ,1,-1)>0,NODRAW, COLORGREEN;{6}
區間:=COUNT(BU,BARSLAST(BU)+1)=1 AND COUNT(止損,BARSLAST(BU>0)+1)
=0 AND COUNT(CROSS(0,IF(MA(CLOSE,1)>IF(BF=-1,MA(HIGH,1.01),MA(LOW,1.01))
,1,-1)), BARSLAST(BU>0)+1)=0,NODRAW,COLORLIMAGENTA;{COLOR696960;6}
魚進龍門:(COUNT(BU,BARSLAST(BU)+1)=1 AND COUNT(止損,BARSLAST(BU>0)+1)
=0 AND COUNT(CROSS(0,IF(MA(CLOSE,1)>IF(BF=-1,MA(HIGH,1.01),MA(LOW,1.01)) ,1,-1)), BARSLAST(BU>0)
+1)=1 AND CROSS(0,IF(MA(CLOSE,1)>IF(BF=-1,MA(HIGH,1.01),MA(LOW,1.01)) ,1,-1)))
OR 止損,NODRAW;
STICKLINE(魚進龍門>0,0,4,3,0),COLORYELLOW;
DRAWTEXT(魚進龍門,3.77,'←魚躍龍門'),COLORMAGENTA;
RSVP:=(C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*20-20;
KV:=SMA(RSVP,3,1);
DV:=SMA(KV,3,1);
JV:=3*KV-2*DV;
ZDZK1:=EMA(JV,6);
ZDZK2:=REF(ZDZK1,1);
鳳:=IF(ZDZK1>=ZDZK2,ZDZK1+2,ZDZK2);
雉:=IF(ZDZK2-ZDZK1,ZDZK2,ZDZK1);
MTM:=C-REF(C,1);
龍:=30*EMA(EMA(MTM,50),50)/EMA(EMA(ABS(MTM),61),61);
凰:=MA(龍,6);
龍鳳呈祥:=CROSS(凰<龍,0.13) AND 龍>鳳 AND 鳳>雉;
STICKLINE(龍鳳呈祥,3,0,1,0),COLORWHITE;
DRAWTEXT(龍鳳呈祥,3.02,' 龍鳳呈祥'),COLORWHITE;
AA:=HHV(HIGH,25)-LLV(LOW,25);BB:=CLOSE-LLV(LOW,25);
CC:=AA/EMA(BB,5);
DD:=EMA(BB/AA*100,5);
EE:=CLOSE-LLV(LOW,10);
FF:=HHV(HIGH,25)-LLV(LOW,10);
王婆:=COUNT(CROSS(CC,DD),7)>0 AND REF(CC,2)<REF(CC,1) AND CC<REF(CC,1)
AND COUNT(COUNT(CROSS(CC,DD),7)>0 AND REF(CC,2)<REF(CC,1)
AND CC<REF(CC,1),5)=1 OR CROSS(EMA(EE/FF*4,4),0.3);
WVAR1V:=REF(CLOSE,1);
WVAR2V:=SMA(MAX(CLOSE-WVAR1V,0),7,1)/SMA(ABS(CLOSE-WVAR1V),7,1)*100;
X1:=FILTER(REF(WVAR2V,1)<20 AND WVAR2V>REF(WVAR2V,1),5);
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖離:=MA(BIAS,3);
X2:=CROSS(BIAS,乖離) AND 乖離<-9.5;
偷偷約會:=X1 OR X2;
VAR1V:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR2V:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR3V:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR4V:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR5V:=(VAR2V+2*VAR3V+3*VAR4V)/7;
VAR6V:=MA(VAR5V,1);
西門赴約:=VAR6V<=-8;
武大出攤:王婆 AND 偷偷約會 AND 西門赴約,COLORRED,NODRAW;
{STICKLINE(C>0,1.25,1.25,3,0),COLORYELLOW;{COLOR555555;}
STICKLINE(魚躍龍門>0,0,3.8,4,0),COLORRED;{紅色柱}
DRAWTEXT(魚躍龍門,3.5,'★有魚徘徊'),COLORYELLOW;
STICKLINE(CROSS(王婆牽線,0)AND 潘金蓮<40,0,2.8,1,0),COLORGREEN;
STICKLINE(EXIST(機會來臨,7) AND CROSS(A1X,潘金蓮)AND 潘金蓮<A5X AND 潘金蓮<15,0,3,1,0)
,COLORBROWN;
DRAWTEXT(EXIST(機會來臨,7) AND CROSS(A1X,潘金蓮)AND 潘金蓮<A5X AND 潘金蓮<15,2.7,'←寂 寞 難 耐')
,COLORCYAN;
STICKLINE(武大出攤,2.08,0,4,0),COLORCYAN;{COLOR007FFF;}
DRAWTEXT(武大出攤,1.8,' ---最低買點'),COLORCYAN;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
蝦將:=IF(CROSS(RSI,11),2,0),COLORWHITE,POINTDOT;
蟹兵:=STICKLINE(蝦將,1.8,0,2,0),COLORWHITE;
STICKLINE(蝦將,1.8,0,2,0),COLORWHITE;
DRAWTEXT(蟹兵,1.8,' ---蟹兵'),COLORYELLOW;
VAR7:=EMA(AMOUNT/VOL/100,3);
VAR8:=EMA(VAR7,88);
VAR9:=EMA(VAR7,88)*0.85;
VARA:=VAR9*0.87;
VARB:=LOW<VARA AND CLOSE>REF(CLOSE,1)*1.02;
白龍馬:=STICKLINE(FILTER(VARB,6),2,0,2,0),COLORLIBLUE;
STICKLINE(FILTER(VARB,6),2,0,2,0),COLORLIBLUE;
DRAWTEXT(白龍馬,1.6,' ---白龍馬'),COLORWHITE;
VARF:=(2*CLOSE+HIGH+LOW)/4;
VA4:=LLV(LOW,34);
VA5:=HHV(HIGH,34);
VA6:=EMA((VARF-VA4)/(VA5-VA4)*100,6);
VA7:=EMA(0.667*REF(VA6,1)+0.333*VA6,4);
鳳尾魚:=STICKLINE(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND
REF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0),1.5,0,3,0),COLORBLUE;
STICKLINE(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND
REF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0),1.5,0,6,0),COLORBLUE;
DRAWTEXT(鳳尾魚,1.3,' ---定海神針'),COLORYELLOW;
DRAWTEXT(CROSS(王婆牽線,0)AND 潘金蓮<40,2.3,'--鳳尾魚'),COLORWHITE;

通達信四季發財指標公式

 

相關文章

高手二肖中特