載入中...
在線檢測未來函數
載入中...

通達信CCI買賣點優化指標公式

來源:Internet,編輯:股旁網,2019-03-07

DRAWGBK(O>C,RGB(40,40,40),RGB(0,0,40),0,'01',0); {背景不要可刪除}
N:=14;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
RSI1:=CCI;
AA:=REF(RSI1,N)=HHV(RSI1,2*N+1);
BB:=BACKSET(AA,N+1);
CC:=FILTER(BB,N) AND RSI1=HHV(RSI1,N+1);
A1:=BARSLAST(REF(CC,1));
背離:REF(CLOSE,A1+1)<CLOSE AND REF(RSI1,A1+1)>RSI1 AND CC;
DRAWLINE(CC,RSI1,FILTER(頂背離>0,5),RSI1,0),COLORGREEN,LINETHICK1;
DRAWICON(頂背離,CCI*0.9,6);
AA2:=REF(RSI1,N)=LLV(RSI1,2*N+1);
BB2:=BACKSET(AA2,N+1);
CC2:=FILTER(BB2,N) AND RSI1=LLV(RSI1,N+1);
A2:=BARSLAST(REF(CC2,1));
底背離:REF(CLOSE,A2+1)>CLOSE AND REF(RSI1,A2+1)<RSI1 AND CC2;
DRAWLINE(CC2,RSI1,FILTER(底背離>0,5),RSI1,0),COLORMAGENTA,LINETHICK1;
DRAWICON(底背離,CCI*1.1,5);
上升:IF(CCI>REF(CCI,1),CCI,DRAWNULL),LINETHICK1,COLORRED,DOTLINE;
X:=CROSS(CCI,-100);
DRAWICON(X,-150,7);
M:=CROSS(100,CCI);
DRAWICON(M,150,8);
IF(CCI>=100,CCI,DRAWNULL),COLORGREEN;
IF(CCI<=-100,CCI,DRAWNULL),COLORRED;
頂部:100,COLORBLUE,LINETHICK1;
底部:-100,COLORRED,LINETHICK1;
STICKLINE(CCI>100,100,CCI,0.5,0), COLORGREEN;
STICKLINE(CCI<-100,-100,CCI,0.5,0), COLORRED;

通達信CCI買賣點優化指標公式

 

相關文章

高手二肖中特