在線檢測未來函數

通達信兩周期CCI指標公式

來源:Internet,編輯:股旁網,2019-06-14

{CCI}
TYP:=(HIGH+LOW+CLOSE)/3;
CCI84:(TYP-MA(TYP,84))/(0.015*AVEDEV(TYP,84)),COLORLICYAN;
DRAWBAND(100,RGB(0,50,50),CCI84,RGB(100,10,0));
CCI14:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),COLORLIGREEN;
{短線精靈}
主力資金線:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
VAR2LL:=HHV(主力資金線>20,10);
STICKLINE(VAR2LL AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),CCI14,100,1,0),COLORRED; {危險:};
VAR1T:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR2T:=2*ABS(VAR1T);
VAR5T:=(HIGH+LOW+CLOSE)/3;
VAR6T:=(VAR5T-MA(VAR5T,14))/(0.015*AVEDEV(VAR5T,14));
VAR7T:=(VAR5T-MA(VAR5T,70))/(0.015*AVEDEV(VAR5T,70));
VAR8T:=IF(VAR6T>=150 AND VAR6T<200 AND VAR7T>=150 AND VAR7T<200,10,0);
VAR9T:=IF(VAR6T<=-150 AND VAR6T>-200 AND VAR7T<=-150 AND VAR7T>-200,-10,VAR8T);
VARAT:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VARBT:=100-ABS(VARAT);
預警系統:=IF(VAR7T>=200 AND VAR6T>=150,100,IF(VAR7T<=-200 AND VAR6T<=-150,-100,VAR9T))+0;
DRAWBAND(預警系統,RGB(10,100,10),0,RGB(100,10,0));
天線:=IF(VARBT<90,VARBT,60);
紅軍:=IF(VAR1T>0,VAR1T,0),COLORRED, LINESTICK;
VAR24:=紅軍>48 AND 預警系統>60 AND 天線<100;
DRAWICON(COUNT(CROSS(2,預警系統),15)>=1 AND CROSS(100,CCI14),100,2);
DRAWICON(COUNT(CROSS(預警系統,-2),15)>=1 AND CROSS(CCI14,0),-100,1);
350,COLORYELLOW,POINTDOT;
220,COLORMAGENTA,POINTDOT;
水面:100,COLORBLUE;
0,COLORRED;
-100,DOTLINE;
-220,COLORBLUE,POINTDOT;
CI:EMA(CCI,5);界:100;界0:0;界1:-100;
IF(CCI>=REF(CCI,1),CCI,DRAWNULL),COLOR0000FF,LINETHICK3;

通達信兩周期CCI指標公式

 

相關文章

高手二肖中特