在線檢測未來函數

通達信改布林軌道主圖指標公式

來源:Internet,編輯:股旁網,2019-06-17

M:=20;
{漲停變色}
CA:=REF(C,1);
漲停1:=IF((C-CA)*100/CA>=(10-0.01*100/CA),1,0);
STICKLINE(漲停1,OPEN,CLOSE,2,0),COLORYELLOW;
跌停:=IF((CA-C)*100/CA>=(10-0.01*100/CA),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORBLUE;
BOLL:MA(CLOSE,M);
IF(BOLL>=REF(BOLL,1),BOLL,DRAWNULL),COLORRED;
IF(BOLL<REF(BOLL,1),BOLL,DRAWNULL),COLORGREEN,LINETHICK2;
UB:BOLL+2*STD(CLOSE,M)COLORYELLOW;
LB:BOLL-2*STD(CLOSE,M)COLORMAGENTA;
MA5:MA(C,5)COLORWHITE,LINETHICK1;
IF(C>=MA(C,5),MA(C,5),DRAWNULL),COLOR9933DD,LINETHICK2;
X1:=(C+L+H)/1.5;
X2:=EMA(X1,3);
X3:=EMA(X2,2.5);
DRAWICON(CROSS(X2,X3),L*0.98,9),COLORRED;
昨日中軌:=REF(C,1)>BOLL;
回踩中軌:=(L-BOLL)/L<=0.01 AND (L-BOLL)/L>=-0.01 AND C>BOLL AND C>O;
中軌連漲:=UPNDAY(BOLL,3);
回踩布林中軌:=回踩中軌 AND 昨日中軌 AND 中軌連漲,COLORLIRED;
DRAWICON(回踩布林中軌,L*0.995,41);
收口:=(UB-LB)/LB<=0.25;
上穿軌道:=CROSS(C,BOLL) OR CROSS(C,UB);
中軌向上:=BOLL>REF(BOLL,1) OR BOLL=REF(BOLL,1);
布林收口選股:=收口 AND 上穿軌道 AND 中軌向上;
DRAWICON(布林收口選股,L*0.985,23);
昨日上軌:=REF(CROSS(C,UB),1);
回踩上軌:=(L-UB)/L<=0.01 AND (L-UB)/L>=-0.01 AND C>UB AND C>L;
回踩上軌選股:=昨日上軌 AND 回踩上軌;
DRAWICON(回踩上軌選股,L*0.975,33);
{臨界點}
UP1:=23;
UPPER:(1+UP1/100)*MA(CLOSE,25),COLOR404088,LINETHICK2;
{東方不敗箭頭}
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
DRAWICON(VAR19,L*0.98,30);

通達信改布林軌道主圖指標公式

 

相關文章

高手二肖中特