在線檢測未來函數

MACD的DIFF和DEA雙線背離的劃線公式

來源:Internet,編輯:股旁網,2019-06-17

編寫要求:

MACD的DIFF和DEA雙線背離的劃線公式。

股旁網解答:

DIFF:EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA), COLORSTICK;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
A3:=BARSLAST(REF(CROSS(DEA,DIFF),1));
底背離:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
底背離2:=REF(CLOSE,A3+1)>CLOSE AND DEA>REF(DEA,A1+1) AND CROSS(DEA,DIFF);
STICKLINE(底背離,0,0.1,8,0),COLORRED;
STICKLINE(底背離2,0,0.1,8,0),COLORYELLOW;
DRAWLINE(A1=0,DEA,底背離,DEA,0),COLORRED,LINETHICK2;
DRAWLINE(A3=0,DIFF,底背離2,DIFF,0),COLORYELLOW,LINETHICK2;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
A4:=BARSLAST(REF(CROSS(DIFF,DEA),1));
頂背離:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
頂背離2:=REF(CLOSE,A4+1)<CLOSE AND REF(DEA,A4+1)>DEA AND CROSS(DIFF,DEA);
DRAWLINE(A2=0,DEA,頂背離,DEA,0),COLORGREEN,LINETHICK2;
DRAWLINE(A4=0,DEA,頂背離2,DIFF,0),COLORCYAN,LINETHICK2;

相關文章

股票公式月點擊榜

股票公式年點擊榜

股票公式總點擊榜

高手二肖中特